Arduino Mega R3 with Dragino LoRa Shiel 1.4 no JoinAccept with OTAA

My HW Arduino (RobotDyn) Mega R3 2560
LoRa Hat Dragino LoRa Shield V1.4
Arduino IDE 1.8.19
My SW: Example → MCCI LoRaWAN Lmic library → ttn-otaa
APPEUI[8]= 0000000000000000

TTN Settings
FrequencyPlan: Europe 863-870 MHz (SF12 for RX2) or Europe 863-870 MHz (SF9 for RX2) I’ve tried both
LoRaWAN Version MAC V1.0.3
Activation Mode: OTAA

At the Applications Console I see “No Activity yet”
Live data window is empty

Arduino Monitor:
Packet queued
253915: EV_TXSTART
647164: EV_JOIN_TXCOMPLETE: no JoinAccept
4410587: EV_TXSTART
4803839: EV_JOIN_TXCOMPLETE: no JoinAccept

If I start it with ABP, everything goes fine

Which switch have I forgotten or set incorrectly?
I am grateful for every tip

Since ABP works, the device is able to transmit.

You’re not receiving down links.
This could be for a number of reasons.

  • the JoinRequest is being discarded by the gateway (i have seen this happen for AppEUI == 0 and some packet forwarderes)
  • the JoinRequest is fowarded to TTN but the credentials don’t match for some reason
  • the credentials match, a response is forwarded, but it’s dropped by the gateway because it gets to the gateway too late
  • the response is forwarded to the gateway, but there’s currently no bandwidth available at the gateway (dropping again)
  • the gateway broadcasts the response, but the device RX path is not working because you have to switch the antenna
  • the gateway broadcasts the response, but the device doesn’t listen at the right time.

I’ve seen all of these problems.

Have you tried two nodes using the Raw sketch, to confirm that basic RX works – that will start to bifurcate the problem.

You can also look closely at the gateway traffic logs in the console and see if the gateway forwarded the join accept.

You can also look closely at the device information in TTN V3 and see whether it has a DevAddr assigned; if so, the network has seen the Join Request and responded.

Good luck!